सवाल "प्रेषण कैसे ठीक करें: प्रमाणीकरण विफल 534 5.7.14"


मैं एसएसएच रूट लॉगिन पर ई-मेल अलर्ट बनाने की कोशिश कर रहा हूं इसलिए मुझे इंस्टॉल करना पड़ा ssmtp तथा मेल उपयोगिता।

फिर मैंने कॉन्फ़िगर किया ssmtp.conf निम्नानुसार फ़ाइल करें:

# Config file for sSMTP sendmail
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
        #root=postmaster
        #Adding  email id to receive system information
root = rootuser@gmail.com
# The place where the mail goes. The actual machine name is required no
# MX records are consulted. Commonly mailhosts are named mail.domain.com
        #mailhub=mail

mailhub = smtp.gmail.com:587

AuthUser=dmymail@gmail.com
AuthPass=plaintext password
UseTLS=YES
UseSTARTTLS=YES

# Where will the mail seem to come from?
rewriteDomain=gmail.com

# The full hostname

hostname = mailserver
# Are users allowed to set their own From: address?
# YES - Allow the user to specify their own From: address
# NO - Use the system generated From: address
FromLineOverride=YES

साथ ही निम्नानुसार पुनरावृत्तियों:

# Format:       local_account:outgoing_address:mailhub
# Example: root:your_login@your.domain:mailhub.your.domain[:port]

root:rootuser@gmail.com:smtp.gmail.com:25

और मुझे यह त्रुटि मिल रही है:

send-mail: Authorization failed (534 5.7.14 https://support.google.com/mail/bin/answer.py?answer=78754 ni5sm3908366pbc.83 - gsmtp)
Can't send mail: sendmail process failed with error code 1

लेकिन यह काम नहीं किया। कृपया इसे हल करने में मेरी मदद करें


52
2017-10-10 17:09


मूल


के संभावित डुप्लिकेट sSMTP बाहरी मेल सर्वर SMTP का उपयोग कर संदेश भेजने में असमर्थ - mailq
कई महीनों तक काम करने के बाद कल रात यह त्रुटि मिली। - ceving
सभी सुझाए गए कदमों को करने के बाद भी यह असफल रहा जब तक कि मैं सही पासवर्ड का उपयोग नहीं कर रहा था, भले ही मैंने अपना gmail.com पासवर्ड बदल दिया ... शायद यह एक नई Google सुरक्षा सावधानी - Scott Stensland
@seving उपाय क्या था? आपने यह कैसे फिक्स किया? - 3kstc


जवाब:


इस मुद्दे को ठीक करने में एक से अधिक कदम लग सकते हैं

  1. पहले उल्लेख किया गया कदम उठाओ। अपने Google ईमेल खाते में लॉग इन करें और फिर इस लिंक पर जाएं: https://www.google.com/settings/security/lesssecureapps और चालू करने के लिए "कम सुरक्षित ऐप्स के लिए एक्सेस" सेट करें। यह देखने के लिए परीक्षण करें कि क्या आपकी समस्या हल हो गई है। यदि यह हल नहीं किया गया है, क्योंकि यह मेरे लिए नहीं था, तो चरण # 2 जारी रखें।

  2. के लिए जाओ https://support.google.com/accounts/answer/6009563 (शीर्षक: "पासवर्ड गलत त्रुटि")। यह पृष्ठ कहता है "तीसरे पक्ष के ऐप्स का उपयोग करके Google में साइन इन करते समय आपको" पासवर्ड गलत "त्रुटि (उर्फ 534-5.7.14) क्यों दिखाई दे सकती है। कुछ मामलों में भी यदि आप अपना पासवर्ड सही टाइप करते हैं। "  यह पृष्ठ कोशिश करने के लिए चीजों के 4 सुझाव देता है।

मेरे लिए, पहला सुझाव काम किया:

  • के लिए जाओ https://g.co/allowaccess एक अलग डिवाइस से जिसे आपने पहले अपने Google खाते तक पहुंचने के लिए उपयोग किया था और निर्देशों का पालन किया था।
  • अवरुद्ध ऐप से फिर से साइन इन करने का प्रयास करें।

चरण # 2 में दिए गए पृष्ठ पर तीन और सुझाव दिए गए थे, लेकिन मैंने उन्हें आजमाया नहीं क्योंकि रेडक्ट किए गए लिंक पर जाने और निर्देशों का पालन करने के बाद, सबकुछ काम करना शुरू कर दिया जैसा कि करना चाहिए।


73
2018-03-01 01:42



विकल्प 1. मेरे लिए काम किया - Patrick Forget
एफवाईआई, सुरक्षा सेटिंग्स में, व्यवसाय के लिए Google ऐप्स का उपयोग करते समय आप इसे अपनी पूरी कंपनी के लिए सक्षम कर सकते हैं। - Travis Reeder
+1, विकल्प 1 के बाद g.co/allowaccess पूरी तरह से काम किया। - greg_data
मुझे कुछ मिनट लगे लेकिन मुझे पता चला कि एडमिन कंसोल में पूरे संगठन के लिए कैसे सक्षम किया जाए सुरक्षा > मूल सेटिंग्स > कम सुरक्षित ऐप्स > पहुंच लागू करें ... जो अतिरिक्त भ्रम के लिए शीर्षक में "उन्नत सुरक्षा सेटिंग्स" दिखाता है (हालांकि मुझे उन्नत सुरक्षा सेटिंग्स के माध्यम से उस पृष्ठ का लिंक नहीं मिला ...)। उलझन में? मैं भी! - isapir


यह मेरे लिए काम किया।

1) अपने जीमेल खाते में लॉग इन करें।

2) जाओ https://www.google.com/settings/security/lesssecureapps और इस सुविधा को चालू करें।

3) जाओ https://accounts.google.com/DisplayUnlockCaptcha और जारी रखें पर क्लिक करें।

फिर आप अपने जीमेल खाते से अपने अतिरिक्त ईमेल पते को प्रमाणित कर सकते हैं।

संपादित करें: मेरे मामले में यह smtp.gmail.com voice87 के बजाय smtp.gmail.com लिखने में मदद मिली।


10
2017-12-29 03:27





मेरे पास यह वही समस्या थी, अपने जीमेल खाता सुरक्षा सेटिंग्स पर नज़र डालें और www.google.com/settings/security से "कम सुरक्षित ऐप्स तक पहुंच" सक्षम करें।

यह जादूगर रूप से काम करना शुरू कर देगा।


4
2017-10-14 17:45



यह सहायक है और मैंने www.google.com/settings/security से "कम सुरक्षित ऐप्स तक पहुंच" की अनुमति देकर मेरी जीमेल खाता सुरक्षा सेटिंग्स में परिवर्तन लागू करने के बाद एक ही समस्या तय की है। संबंधित सहायक लिंक पाया जा सकता है यहाँ


इस समस्या को ठीक करने के लिए, आपको यह करना होगा:

1) वेब ब्राउज़र का उपयोग कर अपने जीमेल खाते में लॉग इन करें।

2) अपने खाते तक पहुंचने के लिए एप्लिकेशन सक्षम करने के लिए इस लिंक पर क्लिक करें: https://accounts.google.com/b/0/DisplayUnlockCaptcha

3) चरण को पूरा करने के लिए जारी रखें बटन पर क्लिक करें।

4) अब अपनी PHP स्क्रिप्ट से ईमेल भेजने के लिए पुनः प्रयास करें। यह काम करना चाहिए।


3
2018-01-09 10:31



यह वास्तव में लिनक्स कोर इंस्टॉल के लिए उत्तर नहीं हो सकता है। और मुझे पूरा यकीन नहीं है कि यह डेमन पुनरारंभ होने के बाद जारी रहेगा। तुम बेहतर हो असुरक्षित ऐप निर्देशों का पालन करें। - Reaces
यह मेरे लिए काम किया। लिनक्स कोर स्थापित करें। मैं एक और कंप्यूटर से लॉग इन किया। - Michal Sokolowski


ऐसा इसलिए होता है क्योंकि Google ने हाल ही में एक नीति परिवर्तन लागू किया है, जो कि अपने स्वयं के शब्दों में, ईमेल प्रमाणीकरण को मजबूत करने के लिए बदलावों की एक श्रृंखला में से एक है, और Google उत्पादों द्वारा प्रमाणीकरण तोड़ने वाले किसी भी अभ्यास को समाप्त करता है।

सुरक्षा सेटिंग्स टैब आदि में "कम सुरक्षित ऐप्स की अनुमति दें" विकल्प सक्षम करने के लिए, SMTP सर्वर के लिए बंदरगाहों को बदलने के लिए सुझाव देने के कई विकल्प हैं।

एक समाधान जो काम करता है, AuthUser के लिए जीमेल के दो चरण प्रमाणीकरण को सक्षम करना है, एक ऐप विशिष्ट पासवर्ड उत्पन्न करना है, और "इस रूप में मेल भेजें" विकल्प सेट करते समय इस पासवर्ड का उपयोग जीमेल पासवर्ड के रूप में करें। एक बार जब आप केवल ऐप बनाते हैं और इसका इस्तेमाल करते हैं /etc/ssmtp/ssmtp.confपर AuthPass=, आप दो चरण सत्यापन रद्द किए बिना दो चरण सत्यापन अक्षम कर सकते हैं।


1
2017-08-31 15:34





क्या आपने दिए गए लिंक का पालन किया है और निर्देशों को पढ़ा है? इसे ठीक करने का तरीका है।

मैं शर्त लगाता हूं कि आपने गलत उपयोगकर्ता नाम या पासवर्ड दर्ज किया है।

यदि वे वास्तव में सही हैं, तो सत्यापित करें कि आप एक ही पोर्ट का उपयोग करते हैं। ऊपर आप 587 निर्दिष्ट करते हैं जबकि नीचे आपके द्वारा निर्दिष्ट 25।

तो यह निर्दिष्ट करने के लिए शायद ठीक नहीं है UseTLS तथा UseSTARTTLS। पोर्ट 587 पर पोर्ट 25 के साथ UseSTARTTLS का उपयोग करें, यूटीटीएलएस का उपयोग करें।

अंत में आपका होस्टनाम समान नहीं है "मेलसेवर"। एक एफक्यूडीएन का प्रयोग करें।


0
2017-10-10 17:36



@ mmailq, आपके समाधान के अनुसार मैंने दोनों conf फ़ाइल पर पोर्ट नंबर को 587 में बदल दिया और मुझे यकीन है कि उपयोगकर्ता नाम और पासवर्ड सही हैं। - Connect
@@ mmailq, एफक्यूडीएन क्या होना चाहिए? मेरा सर्वर होस्टनाम मेलसेवर है। - Connect
@@ mmailq, नहीं, यह काम नहीं कर रहा है एक ही त्रुटि आ रही है। - Connect


मैंने इसे एक नया जीमेल खाता बनाकर तय किया, केवल मेल भेजने के लिए, दो चरण-एथ सक्रिय किया, और एक ऐप पासवर्ड जेनरेट किया।

यह एक सम्मोहन की तरह काम करता है!


0
2018-03-05 07:46