सवाल इसका क्या अर्थ है: भंडार प्राथमिकता सुरक्षा के कारण संकुल को छोड़ दिया गया है


यम के साथ अद्यतन करते समय मुझे निम्न संदेश प्राप्त होता है:

yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * atomic: www7.atomicorp.com
 * base: mirror.de.leaseweb.net
 * extras: mirror.de.leaseweb.net
 * updates: mirror.de.leaseweb.net
118 packages excluded due to repository priority protections
Setting up Update Process
No Packages marked for Update

इसका क्या मतलब है ? इन पैकेजों को कैसे स्थापित करें?


53
2017-09-17 09:27


मूल




जवाब:


कुछ पैकेज एक से अधिक भंडार द्वारा आयोजित किए जाते हैं। priorities प्लगइन अन्य repos से डुप्लिकेट प्रविष्टियों को छोड़कर, उच्च प्राथमिकता भंडार से संकुल का चयन करें।


33
2017-09-17 09:53





जो मैं समझता हूं, उससे यह त्रुटि उत्पन्न होती है priorities पावेल द्वारा नोट किया गया प्लगइन।

200 9 में, द यम का रखरखाव उल्लेख किया कि उन्होंने आशा व्यक्त की कि लोग इसका उपयोग नहीं करेंगे priorities। प्राथमिकता प्लगइन को अक्षम करने के लिए, संपादित करें /etc/yum/pluginconf.d/priorities.conf और सेट करें enabled = 0। इस बदलाव के बाद, अगली बार जब आप दौड़ें yum update, आपको कोई प्राथमिकता सुरक्षा नहीं मिलनी चाहिए।


47
2018-06-26 17:33



मैंने बस इसे ऊपर उठाने के लिए साइन इन किया। मेरा openssh नवीनतम संस्करण में अपडेट नहीं हो रहा था क्योंकि प्राथमिकता सेटिंग सक्षम थी। इससे मेरी मदद की। धन्यवाद! - manish_s
हां, 'सेट सक्षम =' मेरे लिए काम किया। यम से अधिक जानकारी छेड़छाड़ करना अच्छा होगा - जैसे प्रभावित पैकेजों के नाम और वे जिन रिपॉजिटरीज से आए हैं। (क्या यह एक अलग सवाल है?) - bobgus
ए yum erase yum-plugin-priorities काम भी करता है - mbirth
आप प्लगइन को भी अक्षम कर सकते हैं yumइस पंक्ति के साथ कमांड लाइन: --disableplugin=priorities - KJH


यदि आप जानना चाहते हैं कि प्राथमिकता सुरक्षा के कारण आप कौन से पैकेज बहिष्कृत हैं, तो आप इसका उपयोग कर सकते हैं

yum list updates -d3

23
2018-04-23 16:45