सवाल गिटलैब बाहरी वेब पोर्ट नंबर सेट करें


मैं गिटलैब के डिफ़ॉल्ट पोर्ट 80 को कस्टम पोर्ट नंबर में कैसे बदलूं?

मैंने कोशिश की दो दृष्टिकोण हैं:

पोर्ट को /etc/gitlab/gitlab.rb में सेट करें

external_port "8888"

फिर पुन: कॉन्फ़िगर करें:

gitlab-ctl reconfigure

पोर्ट को /var/opt/gitlab/gitlab-rails/etc/gitlab.yml में सेट करें

production: &base
  #
  # 1. GitLab app settings
  # ==========================

  ## GitLab settings
  gitlab:
    ## Web server settings (note: host is the FQDN, do not include http://)
    host: gitlab.blitting.com
    port: 8888
    https: false

फिर gitlab पुनरारंभ करें

gitlab-ctl stop
gitlab-ctl start

इनमें से दोनों के साथ, गिटलैब डिफ़ॉल्ट 80 पोर्ट नंबर पर चल रहा है।


56
2018-03-31 00:36


मूल


Gitlab-http.conf nginx कॉन्फ़िगरेशन को अद्यतन करना, क्या सही प्रक्रिया है? - Jason Sturges


जवाब:


चाड कार्बर्ट उत्तर अभी भी लागू होता है लेकिन संस्करण 7.0.0 के लिए अतिरिक्त जोड़ना चाहता है।

अपने टेक्स्ट एडिटर में "/etc/gitlab/gitlab.rb" खोलें जहां वर्तमान में मेरे पास है external_url  http://127.0.0.1/ या उसके समान। मुझे बाहरी नंबर को डीएनएस के साथ बदलना पड़ सकता है जिसमें पोर्ट नंबर (उदाहरण के लिए 'http: //gitlab.com.local: 81 /') फिर कमांड का उपयोग करके पुन: कॉन्फ़िगर करें "सुडो गिटलैब-सीटीएल पुन: कॉन्फ़िगर करें" गिटलैब अब पोर्ट 81 पर काम कर रहा है।

क्रमशः:

  1. sudo -e /etc/gitlab/gitlab.rb
  2. परिवर्तन external_url से yourdomain.com सेवा मेरे yourdomain.com:9999
    9999 -> पोर्ट जिसे आप इसे चलाने के लिए चाहते हैं
  3. sudo gitlab-ctl reconfigure

73
2018-06-26 11:34



मेरे लिए gitlab अब 8080 और 8081 (पोर्ट जो मैंने जोड़ा) दोनों के माध्यम से सुलभ है। कोई विचार है कि मैं 8080 कैसे मुक्त कर सकता हूं? - DaSh
इसे रोकना और इसे फिर से शुरू करना इस मुद्दे को हल करता है। - DaSh
यदि यह काम नहीं करता है, तो लॉग का उपयोग कर जांचें gitlab-ctl tail यह पता लगाने के लिए कि बंदरगाह टकराते हैं या नहीं। - dusan
क्या इसके लिए एक वैकल्पिक कमांड है gitlab-ctl reconfigure अगर मेरे पास नहीं है gitlab-ctl? बस पुनरारंभ करना चाहिए, है ना? - icedwater
कॉन्फ़िगरेशन फ़ाइल में "#unicorn ['port'] = '8080'" मान देखें। - emeraldjava


मुझे भी यही समस्या है। मेरे पास मेरा नहीं है gitlab.rb आपके जैसे ही स्थान पर, लेकिन इसे डीपीकेजी के माध्यम से स्थापित किया है /opt जिस पथ का आपने उल्लेख किया है।

यदि आपने इसे पैकेज के माध्यम से इंस्टॉल किया है, तो इसमें सभी स्वयं निहित हैं /opt निर्देशिका, तो आप पोर्ट को बदल सकते हैं:

  • /opt/gitlab/embedded/conf/nginx.conf
  • /opt/gitlab/embedded/cookbooks/gitlab/templates/default/nginx-gitlab-http.conf.erb

समस्या # 6581: Ubuntu 12.04 पर .deb पैकेज स्थापित - gitlab.yml फ़ाइल में पोर्ट नंबर को अनदेखा किया जाता है


4
2018-04-09 15:21



यह कैसे मदद मिली? मुझे अभी भी इसके साथ कहीं भी नहीं मिल रहा है - गिटलैब पोर्ट 80 का उपयोग करने पर जोर दे रहा है - जो ऐसा नहीं कर सकता क्योंकि अपाचे पहले से ही इसका उपयोग कर रहा है। आपने जो किया उसके बारे में कोई विशिष्टता? उन फ़ाइलों में बंदरगाहों को बदलने से कुछ भी नहीं हुआ। - Hippyjim


डिफ़ॉल्ट पोर्ट नंबर बदलने के लिए बहुत आसान तरीका

gitlab-ctl stop

फ़ाइल को सेंटोस या लिनक्स में संपादित करें: - /var/opt/gitlab/nginx/conf/gitlab-http.conf

परिवर्तन listen *:80; आप जो चाहते हैं उसे पूर्व: - 90

फिर

आदेश न चलाएं- gitlab-ctl reconfigure

अगर gitlab-ctl reconfigure यह डिफ़ॉल्ट रूप से gitlab कॉन्फ़िगर किया गया है और परिवर्तनों को हटा दें।

तो केवल रन-गीटलैब-सीटीएल शुरू करें


3
2018-04-23 06:17



कम से कम omnibus पैकेज के लिए काम नहीं करेगा - ALex_hha


मेरा मुख्य मुद्दा यह था कि नए उपयोगकर्ताओं को सिस्टम द्वारा भेजे गए ईमेल में कस्टम पोर्ट नंबर नहीं मिल रहा था। अन्यथा, पता बार में कस्टम पोर्ट को मैन्युअल रूप से लिखने से उपयोगकर्ताओं को गिटलैब इंस्टॉल किया गया।

मैंने किया यह स्थापित करें पर उबंटू 14.04 Omnibus के बजाय। तो किसी भी तरह से मेरे पास नहीं है gitlab-ctl। (यह अस्तित्व में है /usr/bin, लेकिन symlink का लक्ष्य किसी भी तरह से स्थापित नहीं किया गया था। अगर मुझे वास्तव में करना है तो मैं इसे अलग से ठीक कर दूंगा।)

वैसे भी, मैंने दूसरे दृष्टिकोण का एक संस्करण इस्तेमाल किया, जिसमें सही पोर्ट लिखा गया /home/git/gitlab/config/gitlab.yml:

production: &base
  #
  # 1. GitLab app settings
  # ==========================

  ## GitLab settings
  gitlab:
    ## Web server settings (note: host is the FQDN, do not include http://)
    host: my.gitlab.host.com
    port: 3722

चूंकि मेरे पास नहीं है gitlab-ctl, मैंनें इस्तेमाल किया service:

sudo service gitlab restart

यह मेरे लिए काम किया। नए उपयोगकर्ता जिन्हें मैंने ईमेल भेजा था, उन्हें एक लिंक प्राप्त हुआ जिसमें सही यूआरएल था।


2
2018-02-03 07:14





स्थानीय नेटवर्क पर उबंटू 17.04 और गिटलैब-सी 9.2.2 के साथ

ये कदम मेरे लिए काम करते थे:

  1. संपादित करें gitlab.rb फ़ाइल।

sudo nano /etc/gitlab/gitlab.rb

  1. फ़ाइल के अंत में अपना वैकल्पिक श्रोता बंदरगाह जोड़ें।

nginx['listen_port'] = 8181

  1. यदि आवश्यक हो तो अपाचे बंद करें, और gitlab को फिर से कॉन्फ़िगर करें

sudo service apache2 stop sudo gitlab-ctl reconfigure

  1. यदि आप इसे रोकते हैं तो अपाचे शुरू करें।

sudo service apache2 start

  1. समाप्त हो गया, अब चयनित पोर्ट के साथ आपके आईपी पते पर गिटलैब उपलब्ध है।

'http: // localhost: 8181'


1
2018-06-05 14:40





Centos 6 पैकेज का उपयोग कर अमेज़ॅन लिनक्स में मुझे फ़ाइल को कॉन्फ़िगर करना पड़ा:

/opt/gitlab/embedded/cookbooks/gitlab/attributes/default.rb

और फिर करो

gitlab-ctl reconfigure 

आखिर में पोर्ट परिवर्तन प्राप्त करने के लिए आदेश।


0
2017-11-10 18:31





मैं डेबियन निचोड़ पर गिटलाब 7.5.3 ऑम्निबस 5.2.1 सीआई का उपयोग कर रहा हूं। Nginx के लिए डिफ़ॉल्ट पोर्ट को बदलने के लिए _gitlab_port_ को जोड़ें /etc/gitlab/gitlab.rb:

मेरे /etc/gitlab/gitlab.rb:

external_url = 'gitlab.example.org'
gitlab_rails['gitlab_port'] = 12345

बंदरगाह बदलने के बाद, आपको कॉल करना होगा gitlab-ctl reconfigure तथा gitlab-ctl restart आपके कमांड लाइन में।


0
2017-12-23 16:18