सवाल मैं आरएचईएल संस्करण स्थिर कैसे रख सकता हूं (उदा। आरएचईएल 5.1)?


एक कार्यक्रम के साथ संगतता के लिए:

  • मुझे अपने सर्वरों में से एक को एक विशिष्ट संस्करण में रखना होगा, उदाहरण के लिए रेल 5.1
  • मैं इसे यथासंभव अद्यतन रखना चाहता हूं, लेकिन संस्करणों को बदलने के लिए नहीं।

मुझे क्या करना चाहिए:

यम कॉन्फ़िगर करें?
उपग्रह भंडार को कॉन्फ़िगर करें?


5
2017-09-30 15:26


मूल


आपके आवेदन के लिए सही तरीके से काम करने के लिए आपको विशेष रूप से स्थिर रहने की आवश्यकता क्या है? - MDMarra


जवाब:


Redhat-release-5 सर्वर नामक पैकेज को अपडेट न करें-

$ rpm -qf /etc/redhat-release
redhat-release-5Server-5.3.0.3

उस पैकेज को पिन करना सुनिश्चित करें। यदि आप /etc/yum.conf संपादित करते हैं और इसे इसमें डालते हैं

[main]
exclude=redhat-release-5Server-*

yum उस पैकेज को अपडेट करने से बचना होगा और जो इसके वर्तमान संस्करण में / etc / redhat-release रखेगा।

यकीन नहीं है कि आप यह क्यों चाहते हैं ...


11
2017-09-30 15:38



शीश, डेनिस, आप एक वर्तनी कट्टरपंथी हैं :-) और आपके पास पहले से ही 'स्ट्रंक एंड व्हाइट' बैज है :- डी (मजाक, मजाक) हालांकि टाइपो को ठीक करने के लिए धन्यवाद ... - wzzrd
क्या यह पिनिंग रिलीज के बाद आने वाले अपडेट को रोक रहा है? यदि नहीं, तो मुझे बिंदु नहीं दिख रहा है। - Christophe Drevet-Droguet


आप या तो बाहर कर सकते हैं। आपको मामूली संस्करण के भीतर सभी अपडेट अपडेट मिलेंगे। निर्देश को छोड़कर निर्दिष्ट संकुल को अद्यतन से बाहर रखा गया है। इस मामले में ओएस का संस्करण अपग्रेड नहीं किया जाएगा, लेकिन यह अभी भी उस रिलीज के भीतर सभी संकुल को अपग्रेड करेगा।

यानी आपके मामले में बहिष्कृत लाइन डालने के बाद (आप या तो बहिष्कृत संस्करण डाल सकते हैं), आरएचईएल का संस्करण 5.6 पर रहेगा लेकिन आरएचईएल 5.6 के भीतर कोई भी अपग्रेड लागू होगा।

http://www.phy.duke.edu/~rgb/General/yum_HOWTO/yum_HOWTO.txt


0
2018-01-19 02:57