सवाल एनडीए सक्षम करने के बाद आरडीपी त्रुटि "अनुरोधित फ़ंक्शन समर्थित नहीं है"


मैं अपने सर्वरों में से एक में आरडीपी की कोशिश कर रहा हूं, जो नेटवर्क स्तर प्रमाणीकरण सक्षम है और एनटीएलएमवी 2 को मजबूर किया जा रहा है। यह ठीक काम करता है जब तक सर्वर को अद्यतनों के लिए रीबूट करना पड़ा। अब, मैं अब अपने सर्वर में आरडीपी नहीं कर सकता। मुझे यह त्रुटि आरडीपी के माध्यम से कनेक्ट करने की कोशिश कर रही है:

एक प्रमाणीकरण त्रुटि आई है - अनुरोधित फ़ंक्शन समर्थित नहीं है

यह अनुवाद करता है: एक प्रमाणीकरण त्रुटि आई है। अनुरोध किया गया फ़ंक्शन समर्थित नहीं है

मैंने googling द्वारा मिली कई चीजों की कोशिश की, उदाहरण के लिए यहां वर्णित रजिस्ट्री में अतिरिक्त सुरक्षा पैकेज मूल्य जोड़ना: http://funeasytech.com/rdp-connection-error-of-the-requested-security-package-does-not-exist/ लेकिन यह काम नहीं किया। क्लाइंट पर समूह नीति को न तो बदलकर मेरी समस्या हल हो गई है, जैसा कि यहां बताया गया है: https://stackoverflow.com/questions/17371311/the-function-requested-is-not-supported-exception-when-using-smtpclient-in-azu

समस्या यह है कि मेरे पास इस बॉक्स में केवल भौतिक पहुंच नहीं है, केवल आरडीपी के माध्यम से। सर्वर विंडोज सर्वर 2012 आर 2 मानक चला रहा है, क्लाइंट विंडोज 10 प्रो चल रहा है।

मैं अपने सर्वर तक पहुंच कैसे प्राप्त कर सकता हूं?


37
2017-10-18 22:38


मूल


एक ही समस्या है, कुछ क्लाइंट पक्ष लगता है, क्योंकि मैं अन्य कंप्यूटरों से कनेक्ट कर सकता हूं। विन 10 प्रो पर भी क्लाइंट। क्या आपको कभी समाधान मिला? - toster-cx
मुझे एक ही समस्या है, क्लाइंट 2012R2 स्वयं है, अब कई विंडोज सर्वर से कनेक्ट नहीं हो सकता है। अन्य क्लाइंट काम करते हैं, इसलिए मैं इसे क्लाइंट पर रिमोट सर्वर पर दोष नहीं देता हूं। - Peter Hahndorf
त्रुटि पर विवरण विंडोज इवेंट लॉग में होना चाहिए: Microsoft-Windows-TerminalServices-RDPClient/Operational - Peter Hahndorf
@ toster-cx देरी वाले उत्तर के लिए खेद है, लेकिन नहीं, मुझे कोई समाधान नहीं मिला और मशीन को स्वरूपित करना समाप्त हो गया :( - Freek
@ फ्रीक क्लाइंट मशीन पर ब्लैकबर्ड या इसी तरह के सॉफ्टवेयर का इस्तेमाल करने का कोई मौका? यह मेरे लिए हल हो गया: serverfault.com/questions/818792 - toster-cx


जवाब:


मेरी भी यही समस्या थी। मैंने पाया कि इस मुद्दे को विंडोज अपडेट पैच के साथ करना है जो कि पिछले अपडेट विंडोज अपडेट में मेरे वर्क स्टेशन पर धकेल दिया गया था। एक महत्वपूर्ण सीवीई थी (CVE-2018-0886) आरडीपी के लिए जो एक पैच को ठीक करने की आवश्यकता है।

यदि आप वर्कस्टेशन पैच किया गया है, लेकिन आपका सर्वर नहीं है, तो आपका वर्कस्टेशन कनेक्ट करने में विफल रहेगा।

निम्नलिखित ब्लॉग वेबसाइट से उद्धरण इस मुद्दे के बारे में जानकारी के साथ, आपके पास तीन विकल्प हैं:

  • सीवी-2018-0886 के लिए अपने लक्षित कंप्यूटर को पैच करें (अनुशंसित)
  • स्रोत कंप्यूटर पर कमजोर पैरामीटर को लागू करें (अनुशंसित नहीं)
  • अपने लक्षित कंप्यूटर पर एनएलए अक्षम करें (अनुशंसित नहीं)

मेरे पास सर्वर तक वैकल्पिक पहुंच नहीं थी (केवल दूरस्थ पहुंच), इसलिए मुझे विकल्प 2 चुनना पड़ा ताकि मैं सर्वर पर अपडेट कर सकूं।

मैंने अपने कार्य स्टेशन पर स्टार्ट मेनू खोला, "समूह नीति" की खोज की, समूह नीति संपादित करें पर क्लिक किया। फिर माइक्रोसॉफ्ट स्पेक के बाद, "कंप्यूटर कॉन्फ़िगरेशन -> व्यवस्थापकीय टेम्पलेट्स -> सिस्टम -> प्रमाण-पत्र प्रतिनिधिमंडल" पर जाएं, फिर:

  • सेटिंग एन्क्रिप्शन ओरेकल उपचार "सक्षम" पर सेट
  • नीचे दिए गए विकल्पों में, "सुरक्षा स्तर: से" सेट करें चपेट में

49
2018-05-10 04:11



श्रीमान धन्यवाद। मैं पहले से ही एक घंटे में खोदना। सिस्टम से सुरक्षा को कम करना -> उन्नत काम नहीं किया। माइक्रोसॉफ्ट को एक्सेस अवरुद्ध करने के बजाय, एक चेतावनी, या बेहतर संदेश जोड़ना चाहिए। अनुलेख एन्क्रिप्शन ओरेकल उपचार कुंजी है, जिसे सक्षम होना चाहिए। - TPAKTOPA
बहुत उपयोगी जवाब, धन्यवाद - Tornike Shavishvili
खैर, मेरे पास विंडोज़ 10 होम हैं और कोई समूह नीति नहीं है! - Ali Yousefie
अपडेट करने के बाद मेरी विंडोज 10 मशीन में यह समस्या थी। विंडोज सर्वर 2016 बॉक्स से कनेक्ट नहीं हो सका। सर्वर पर KB4103723 स्थापित, रीबूट किया गया, और अब कनेक्ट हो सकता है। सर्वर 2012 आर 2 केबी 4103725 की आवश्यकता होगी। - root
क्या आपको इस जीपीओ परिवर्तन को लागू करने के बाद अपने क्लाइंट को रीबूट करना है? - RonJohn


देख विंडोज आरडीपी: 'एक प्रमाणीकरण त्रुटि आई है'

विंडोज़ सुरक्षा अद्यतन लागू करने के बाद यह हो रहा है यह सुरक्षा अद्यतन था। यह आपको बताता है कि तदनुसार अपने जीपीओ कैसे बदलें।

Windows अद्यतन KB41037272 को अनइंस्टॉल न करें। और या KB4103718 - सिर्फ इसलिए कि कुछ काम करता है इसका मतलब यह नहीं है कि आपको क्या करना चाहिए!


2
2018-05-11 14:37





मेरे पास रिमोट वीएम के साथ एक ही समस्या थी, केवल आरडीपी पहुंच के साथ। यह मेरे लिए काम किया ...

[HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Policies \ System \ CredSSP \ पैरामीटर]   "AllowEncryptionOracle" = DWORD: 00000002


1
2018-06-11 14:11





यदि आपका लक्ष्य सर्वर विंडोज सर्वर 2016 है, तो पहला पैकेज यह सूची (2018-05 x64- आधारित सिस्टम के लिए विंडोज सर्वर 2016 के लिए संचयी अद्यतन (KB4103723)) मेरे लिए काम किया:

  • लक्ष्य सर्वर पर डाउनलोड और इंस्टॉल करें
  • पुनः आरंभ करें

जैसा कि पहले ही उल्लेख किया गया है, यह अनुशंसित तरीका है और स्रोत मशीनों पर किसी भी अन्य बदलाव की आवश्यकता नहीं है।

विंडोज सर्वर 2012 आर 2 पैकेज के लिए 2018-05 x64- आधारित सिस्टम (KB4103715) के लिए Windows Server 2012 R2 के लिए सुरक्षा केवल गुणवत्ता अद्यतन से यहाँ इस मुद्दे को हल किया।


0
2018-05-25 13:37