सवाल मैं एक आरपीएम डाउनग्रेड कैसे करूं?


मेरे पास एक पैकेज स्थापित संस्करण 3.2 है और मैंने संस्करण 2.4 मैन्युअल रूप से डाउनलोड किया है, मैं पुराने संस्करण को कैसे इंस्टॉल करूं?


38
2018-05-27 01:30


मूल


यह यम के बिना मशीन पर है। - Harley


जवाब:


rpm -Uvh --oldpackage [filename]

--oldpackage आपको पुराने संस्करण स्थापित करने की अनुमति देता है, -U का मतलब है "अपग्रेड", लेकिन इस मामले में यह सिर्फ दूसरे संस्करण को प्रतिस्थापित करेगा। यदि तुम प्रयोग करते हो -i के बजाय -U आप दोनों संस्करणों के साथ स्थापित हो जाएगा।


54
2018-05-27 01:30



vh तर्क यहां वैकल्पिक हैं। केवल -U (या --upgrade) तथा --oldpackage जरूरी हैं। - Dave Mooney
rpm -U --force [filename] डाउनग्रेड भी देता है - Sasha
कर्नेल के लिए rpm -i --force <package url / filename> काम करता है (चूंकि आप कई संस्करण रखना चाहते हैं) - Gert van den Berg


आप भी कोशिश कर सकते हैं yum downgrade packagename, आपके सिस्टम पर यम के संस्करण के आधार पर।


13
2018-05-27 01:53



आप सही हैं, लेकिन ओपी ने "बिना मशीन के मशीन पर" निर्दिष्ट किया है, इसलिए या तो टूटा हुआ है या गायब है। - Criggie